<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><![endif]-->
    <title>
	Houston Forward Times | 
    Congressman Al Green’s Statement on House Passage of TrumpCare - Houston Forward Times    </title>
    <meta charset="UTF-8" />
	<link rel="shortcut icon" href="http://forwardtimes.com/wp-content/uploads/2015/12/hftfavicon.ico" />
    <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0">
<!-- This site is optimized with the Yoast SEO plugin v4.7 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://forwardtimes.com/congressman-al-greens-statement-house-passage-trumpcare/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Congressman Al Green’s Statement on House Passage of TrumpCare - Houston Forward Times" />
<meta property="og:description" content="Washington, D.C. (May 5, 2017) – Rep. Al Green (D-TX), a member of the House Financial Services Committee issued the following statement on the House passage of TrumpCare: “The House Republican bill, H.R. 1628, does not save healthcare. This bill will not provide for the health needs of millions of Americans. It will not cover all pre-existing conditions. It will put millions of healthcare dollars in the pockets of the very wealthy. “This legislation will eliminate healthcare coverage for 24 million Americans. This is a careless political scheme to win elections, and line the pockets of the wealthy at the expense of the health and financial futures of hard-working Americans. “In Texas, more than 1.8 million individuals who have gained coverage since the Affordable Care Act (ACA) was implemented could lose coverage if this Trumpcare bill becomes law. Almost 1 million individuals in our state who received financial assistance to purchase Marketplace coverage in 2016 are at risk of having coverage become unaffordable when the Republican Congress eliminates the paid for subsidies in the ACA. “Trumpcare means less care for Americans who will buy cheap health insurance policies and find they are worthless when they get sick and need care. This is tax care for the 400 richest families, who will receive about $7 million healthcare dollars in their pockets if this bill becomes law. “The House GOP passed a bill that may result in the deaths of thousands of working people each year. Trumpcare is fundamentally unsound. The American people will hold House Republicansread more" />
<meta property="og:url" content="http://forwardtimes.com/congressman-al-greens-statement-house-passage-trumpcare/" />
<meta property="og:site_name" content="Houston Forward Times" />
<meta property="article:section" content="National News" />
<meta property="article:published_time" content="2017-05-05T13:13:28-05:00" />
<meta property="article:modified_time" content="2017-05-05T13:18:14-05:00" />
<meta property="og:updated_time" content="2017-05-05T13:18:14-05:00" />
<meta property="og:image" content="http://forwardtimes.com/wp-content/uploads/2017/05/congressman-green.jpg" />
<meta property="og:image:width" content="738" />
<meta property="og:image:height" content="461" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Washington, D.C. (May 5, 2017) – Rep. Al Green (D-TX), a member of the House Financial Services Committee issued the following statement on the House passage of TrumpCare: “The House Republican bill, H.R. 1628, does not save healthcare. This bill will not provide for the health needs of millions of Americans. It will not cover all pre-existing conditions. It will put millions of healthcare dollars in the pockets of the very wealthy. “This legislation will eliminate healthcare coverage for 24 million Americans. This is a careless political scheme to win elections, and line the pockets of the wealthy at the expense of the health and financial futures of hard-working Americans. “In Texas, more than 1.8 million individuals who have gained coverage since the Affordable Care Act (ACA) was implemented could lose coverage if this Trumpcare bill becomes law. Almost 1 million individuals in our state who received financial assistance to purchase Marketplace coverage in 2016 are at risk of having coverage become unaffordable when the Republican Congress eliminates the paid for subsidies in the ACA. “Trumpcare means less care for Americans who will buy cheap health insurance policies and find they are worthless when they get sick and need care. This is tax care for the 400 richest families, who will receive about $7 million healthcare dollars in their pockets if this bill becomes law. “The House GOP passed a bill that may result in the deaths of thousands of working people each year. Trumpcare is fundamentally unsound. The American people will hold House Republicansread more" />
<meta name="twitter:title" content="Congressman Al Green’s Statement on House Passage of TrumpCare - Houston Forward Times" />
<meta name="twitter:image" content="http://forwardtimes.com/wp-content/uploads/2017/05/congressman-green.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Feed" href="http://forwardtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Comments Feed" href="http://forwardtimes.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/forwardtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://forwardtimes.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/css/settings.css?ver=4.6.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='style_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/prettyphoto.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/bootstrap.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/font-awesome.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='responsive_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/responsive.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/themes/medianews-theme/scripts/frontend/functions.js?ver=4.7.4'></script>
<link rel='https://api.w.org/' href='http://forwardtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://forwardtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://forwardtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<meta name="generator" content="WooCommerce 3.0.5" />
<link rel='shortlink' href='http://forwardtimes.com/?p=15069' />
<link rel="alternate" type="application/json+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Fcongressman-al-greens-statement-house-passage-trumpcare%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Fcongressman-al-greens-statement-house-passage-trumpcare%2F&#038;format=xml" />
<div id="fb-root"></div><script>(function(d, s, id) {

	var js, fjs = d.getElementsByTagName(s)[0];

	if (d.getElementById(id)) return;

	js = d.createElement(s); js.id = id;

	js.src = '//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.3';

	fjs.parentNode.insertBefore(js, fjs);

	}(document, 'script', 'facebook-jssdk'));</script>		<script type="text/javascript">
			jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = '160f0f8f1a';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"http://forwardtimes.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});
		</script>
		<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="fe6826430f3c55c1ea5ffe4e97aadc77910ae279d4bd39b95fb0d103f7927acc" async></script>	
			<style type="text/css">
			.pix-colr, .pix-colrhvr:hover,.breadcrumbs ul li.pix-active,#footer p a:hover,.is-countdown span:before,.latest-video .minus-column article:hover h2 a,
	/* New Clases Add*/.event-listing article:hover .text .pix-post-title a,.blog-medium-options li a,.is-countdown span,.pix-blog article:hover h2.pix-post-title a,
	.pix-blog article .post-options li a:hover,.tabs.horizontal .nav-tabs li.active a,.blog-home .tabs.horizontal .nav-tabs li:hover a { color:#00108e !important;
			}
			.pix-bgcolr,.pix-bgcolrhvr:hover,.cart-sec span,.navigation ul ul li:hover > a,.navigation ul > li.current-menu-item > a,
			.navigation ul ul li.current-menu-item > a,.cycle-pager-active,.widget .tagcloud a:hover,.flex-direction-nav li a:hover, .our-team-sec article:hover figure figcaption .pix-post-title a,.footer-widget .widget_newsletter .error,.news-section article:hover .text,.password_protected form input[type="submit"],.team-vertical article figcaption .caption h2,
	#respond form input[type="submit"],#wp-calendar caption,.gallery ul li figure figcaption a,.woocommerce-pagination ul li a:hover,.woocommerce-pagination ul li span,.woocommerce-tabs .tabs .active a, span.match-category.cat-neutral, .event.event-listing article:hover .text .btn,.widget_search form input[type="submit"], .woocommerce .button,.onsale,.gallery ul li:hover .text,.footer-icons .followus a:hover,
	/* New Clases Add*/.searchform button,.tabs.horizontal .nav-tabs li.active a,p.stars span a.active,.event.event-listing.event-listing-v2 .btn-viewall,.featured-title,.next-post-paginate a:hover,
	.pix-feature article .blog-bottom .btn,.pix-feature .featured,.blog-vertical .tab-content header.pix-heading-title h2,header #lang_sel a:hover, header #lang_sel ul ul a:hover,
	.post-tags a:hover,.pix-tittle,nav.navigation > ul > li:hover > a, nav.navigation > ul > li.current-menu-ancestor > a,.table tbody tr:hover,.widget_newsletter label .btn,.detail_figure .mejs-audio.mejs-container .mejs-controls,
	.detail_figure .mejs-audio.mejs-container,.latest-video .minus-column article:hover .uppercase,.flexslider ul li .caption h2,.pagination > ul > li > span.active,.pagination > ul > li > a.active, .pagination > ul > li > a:hover,.widget_nav_menu ul li a:hover, .widget_nav_menu ul li ul li a:hover, .widget_pages ul li a:hover,
	.widget_recent_entries ul li:hover, .widget_recent_comments ul li:hover, .widget_archive ul li:hover, .widget_links ul li:hover, .widget_meta ul li:hover, .widget_layered_nav ul li:hover, .widget_categories ul li:hover,
	h2 .bbp-forum-title,.widget .bbp-forum-title:hover, .widget .bbp-view-title:hover,#respond > h3:after{
				background-color:#00108e !important;
			}
			.pix-bdrcolr ,.tabs.horizontal .nav-tabs li.active,.address-info .text,.subtitle h1,.about-us article .text,blockquote,.blog-gallery .sliderpagination ul li.cycle-pager-active figure:before,
			.footer-icons .followus a:hover,.px-mega-menu > li > a:before,header.pix-heading-title h2:before,.blog-banner-carousel figure:before,.tabs.horizontal .nav-tabs li.active a {
				border-color:#00108e !important;
			}
			#banner .flexslider figcaption .pix-desc h3 span {
			   box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important; 
			}
			.our-team-sec article:hover figure figcaption .pix-post-title a{
				 box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important;   
			}
			.latest-video .minus-column article:hover figure{
				 box-shadow: 0 0 0 2px #00108e;
			}
			.footer-widget{
				background-color:#222222 !important;
			}
			header#header .top-head, .inner-sec{
				background-color:#0d549b !important;
			}
			nav.navigation > ul > li > a, li.sub-mega-menu .px-mega-menu ul li a, .sub-menu > li a, .px-mega-menu li a{
				color:#c6c6c6 !important;
			}
			heade #mainheader{
				background-color:#0d549b !important;
			}
			.sliderpagination ul li:before{
				border-color: transparent #00108e !important;
			}
			.footer-widget .widget_newsletter .error:before{
				border-top-color: #00108e !important;
			}
			body{
				 background:#1e73be url(); 			}
			
			</style>
					<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #0d549b; }
</style>
    </head>
	<body class="post-template-default single single-post postid-15069 single-format-standard custom-background" >
		<div id="wrappermain-pix" class="wrapper wrapper_boxed">
		<!-- Header Start -->
        <div class="mainheader">
            <!-- Top Strip Start -->
            
  
			
            <div class="top-strip">
                <!-- Top Nav Start -->
                <nav class="top-nav">
                    <ul id="top_menus"><li id="menu-item-7948" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/advertise/">ADVERTISE</a></li>
<li id="menu-item-8019" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/houston-forward-times/">ABOUT HFT</a></li>
<li id="menu-item-14098" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://forwardtimes.com/product-category/newspaper-subscription-options/">PURCHASE SUBSCRIPTION</a></li>
<li id="menu-item-8719" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://www.jlcsfoundation.org">JLCS FOUNDATION</a></li>
<li id="menu-item-8239" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/privacy-policy-terms-of-use/">PRIVACY &#038; TERMS</a></li>
<li id="menu-item-7944" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/contact-us/">CONTACT</a></li>
</ul>                </nav>
                <!-- Top Nav End -->
                     
                         <!-- Search Start -->
                         <div class="searchform">
                            		<form id="searchform" method="get" action="http://forwardtimes.com"  role="search">
			
			<input name="s" id="searchinput" value="Search for:" type="text" />
			<button> <i class="fa fa-search"></i></button>
		</form>
	                        </div>
                         <!-- Search End -->
                              </div>
            
                 
            <!-- Top Strip End -->
            <div class="container">
                <!-- Top Header Start -->
                <div class="top-head">
                    <div class="logo">
                        				<a href="http://forwardtimes.com">
                	<img src="http://forwardtimes.com/wp-content/uploads/2016/01/hftlogo.png"  style="width:px; height:px" 
                    alt="Houston Forward Times" />
                </a>
	 		                    </div>
                                             <div class="rightheader">
                            <div class="widget widget_text">
                                <div class="textwidget">
                                    <div class="ads-banner">
                                        <div class="top_banner">
                                        <div class="widget widget_text">			<div class="textwidget"><div class="ads-banner"><div class="sidebar_banner"><a href="http://www.hccs.edu/go" target="_blank"><img src="http://forwardtimes.com/wp-content/uploads/2016/08/HCC_Fall_825x125.jpg" alt="HCC Fall 2016 bnr"></a></div></div></div>
		</div>                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                                    </div>
                <!-- Top Header End -->
                <div class="inner-sec pix-bdrcolr">
                    <nav class="navigation">
                    	<a class="cs-click-menu"><i class="fa fa-bars"></i></a>
                    	<ul id="menus"><li id="menu-item-7877" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-home"><a href="http://forwardtimes.com/">Home</a></li>
<li id="menu-item-7881" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/state-local/">State &#038; Local</a></li>
<li id="menu-item-7878" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://forwardtimes.com/category/national-news/">National News</a></li>
<li id="menu-item-8240" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/business/">BUSINESS</a>
<ul class="sub-menu">
	<li id="menu-item-8667" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/careers/">CAREERS</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-12009" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li id="menu-item-12011" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/commentary/">Commentary</a></li>
	<li id="menu-item-12008" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/jboney-speaks/">JBoney Speaks</a></li>
	<li id="menu-item-12010" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/letters-to-the-editor/">Letters To The Editor</a></li>
	<li id="menu-item-7981" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/">Op-Ed</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-7879" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/sports/">Sports</a></li>
<li id="menu-item-8043" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-7880" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-8714" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-8715" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/fashion/">Fashion</a></li>
	<li id="menu-item-8020" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/health-beauty/">Health &#038; Beauty</a></li>
	<li id="menu-item-8716" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/religious/">Religion</a></li>
	<li id="menu-item-8717" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/society/">Society</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-8718" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/classifieds/">Classifieds</a></li>
</ul>                    </nav>
                    <!-- Wp Sec Start -->
                     		<div class="wp-sec">
					 </div>
		                       <!-- Wp Sec End -->
                </div>
                		<!-- News Section Start -->
		<div class="news-section">
			<!-- Ticker Section -->
			<div class="ticker-sec">
					<div class="outer-newsticker">
    
                    <div class="announcement-ticker">
                <h2>Headlines</h2>                                <script>
                	jQuery(document).ready(function(){
                	    px_jsnewsticker('cls-news-ticker',50,80)
                	});
            	</script>
                <div class="ticker-wrapp">
                    <ul class="cls-news-ticker">
                                                <li>															
                              <a href="http://forwardtimes.com/federal-judge-stops-harris-county-practice-holding-people-cant-pay-bail/">Federal Judge Stops Harris County Practice of Holding People Who Can’t Pay Bail &nbsp; May 3, 2017</a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/inaugural-tsu-maroon-gray-affair-huge-success-800k-raised-scholarships/">Inaugural TSU Maroon and Gray Affair a Huge Success &#8211; Over $800k Raised For Scholarships &nbsp; </a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/influential-houston-real-estate-professional-gerald-w-womack-elected-new-harris-county-housing-authority-chairman/">Influential Houston Real Estate Professional Gerald W. Womack Elected New Harris County Housing Authority Chairman &nbsp; </a>
                          </li>
                                             </ul>
                </div>
                            </div>
                </div>
					 <!-- Follow Us Section -->
				<div class="followus">                    	<a title="" href="https://www.facebook.com/forwardtimesonline" data-original-title="Facebook" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-facebook-square icon"></i></a>
					                    	<a title="" href="https://twitter.com/forwardtimes" data-original-title="Twitter" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-twitter-square icon"></i></a>
					                    	<a title="" href="https://www.instagram.com/forwardtimes/" data-original-title="Instagram" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-instagram icon"></i></a>
					</div>			<!-- Follow Us Section -->
			</div>
		</div>
	    
                </div>
                <!-- News Section Start -->
            </div>
    <!-- Header Close -->
    <div class="clear"></div>
    <div id="main">
        <!-- Inner Main -->
        <div id="innermain">
                      <div class="container">
                <div class="row">

				<!--Left Sidebar Starts-->

<!--Left Sidebar End-->
<div class="col-md-9" >
  <div class="blog blog_detail">
    <article>
      <figure class="detail_figure"><img src="http://forwardtimes.com/wp-content/uploads/2017/05/congressman-green.jpg" alt="" ></figure>      <div class="pix-content-wrap">
        <div class="detail_text rich_editor_text">
           		<ul class="post-options">
        	
        	                	<li><i class="fa fa-user"></i>Written by: <a href="http://forwardtimes.com/author/fts/">Forward Times Staff</a></li>
                                 <li>
                 	<i class="fa fa-clock-o"></i>                    <time datetime="2017-05-05">May 5, 2017                    </time>
                </li>
				<li><span class="fa fa-folder-open"></span> <a href="http://forwardtimes.com/category/national-news/" rel="tag">National News</a></li>		</ul>
	          <div class="subtitle"><h1 class="pix-page-title px-single-page-title">Congressman Al Green’s Statement on House Passage of TrumpCare</h1></div>                      	<div class="detail-blog-text">
            <p>Washington, D.C. (May 5, 2017) – Rep. Al Green (D-TX), a member of the House Financial Services Committee issued the following statement on the House passage of TrumpCare:</p>
<p>“The House Republican bill, H.R. 1628, does not save healthcare. This bill will not provide for the health needs of millions of Americans. It will not cover all pre-existing conditions. It will put millions of healthcare dollars in the pockets of the very wealthy.</p>
<p>“This legislation will eliminate healthcare coverage for 24 million Americans. This is a careless political scheme to win elections, and line the pockets of the wealthy at the expense of the health and financial futures of hard-working Americans.</p>
<p>“In Texas, more than 1.8 million individuals who have gained coverage since the Affordable Care Act (ACA) was implemented could lose coverage if this Trumpcare bill becomes law. Almost 1 million individuals in our state who received financial assistance to purchase Marketplace coverage in 2016 are at risk of having coverage become unaffordable when the Republican Congress eliminates the paid for subsidies in the ACA.</p>
<p>“Trumpcare means less care for Americans who will buy cheap health insurance policies and find they are worthless when they get sick and need care. This is tax care for the 400 richest families, who will receive about $7 million healthcare dollars in their pockets if this bill becomes law.</p>
<p>“The House GOP passed a bill that may result in the deaths of thousands of working people each year. Trumpcare is fundamentally unsound. The American people will hold House Republicans and the Trump Administration accountable.”</p>
            </div>
                    </div>
        <!-- Share Post -->
        <div class="share-post">
          