<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><![endif]-->
    <title>
	Houston Forward Times | 
    Rockets Sign Demetrius Jackson to Two-Way Contract - Houston Forward Times    </title>
    <meta charset="UTF-8" />
	<link rel="shortcut icon" href="http://forwardtimes.com/wp-content/uploads/2015/12/hftfavicon.ico" />
    <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0">
<!-- This site is optimized with the Yoast SEO plugin v5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://forwardtimes.com/rockets-sign-demetrius-jackson-two-way-contract/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rockets Sign Demetrius Jackson to Two-Way Contract - Houston Forward Times" />
<meta property="og:description" content="Houston Rockets General Manager Daryl Morey announced that the team has signed free agent guard Demetrius Jackson to a two-way contract. NBA rosters have expanded from 15 to 17 players with the additional spots available for players under two-way contracts. Teams may have up to two players under two-way contracts who will spend the bulk of the season in the NBA G League (formerly NBA Development League) and not more than 45 days with their NBA team. Only players with four or fewer years of NBA service are able to sign two-way contracts, which can be for either one or two seasons. Jackson (6-1, 201) was the 45th overall pick by Boston in the 2016 NBA Draft following his junior season at Notre Dame. He appeared in five games for the Celtics last season, spending the majority of 2016-17 assigned to their D-League affiliate, the Maine Red Claws. In 32 D-League games, Jackson averaged 14.8 points, 6.0 assists, 5.1 rebounds, and 1.3 steals. In his NBA debut, Jackson had 8 points, 3 rebounds, and 2 assists in 11 minutes of play vs. Denver on Nov. 6, 2016. He averaged 9.3 points, 4.0 assists, 2.8 rebounds, and 2.00 steals while shooting 46.4% from the floor and 50.0% from 3-point range for Boston in the MGM Resorts NBA Summer League 2017." />
<meta property="og:url" content="http://forwardtimes.com/rockets-sign-demetrius-jackson-two-way-contract/" />
<meta property="og:site_name" content="Houston Forward Times" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2017-08-23T11:39:53-05:00" />
<meta property="article:modified_time" content="2017-08-23T11:40:18-05:00" />
<meta property="og:updated_time" content="2017-08-23T11:40:18-05:00" />
<meta property="og:image" content="http://forwardtimes.com/wp-content/uploads/2017/08/Rockets-Two-Way-Contract.jpg" />
<meta property="og:image:width" content="738" />
<meta property="og:image:height" content="461" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Houston Rockets General Manager Daryl Morey announced that the team has signed free agent guard Demetrius Jackson to a two-way contract. NBA rosters have expanded from 15 to 17 players with the additional spots available for players under two-way contracts. Teams may have up to two players under two-way contracts who will spend the bulk of the season in the NBA G League (formerly NBA Development League) and not more than 45 days with their NBA team. Only players with four or fewer years of NBA service are able to sign two-way contracts, which can be for either one or two seasons. Jackson (6-1, 201) was the 45th overall pick by Boston in the 2016 NBA Draft following his junior season at Notre Dame. He appeared in five games for the Celtics last season, spending the majority of 2016-17 assigned to their D-League affiliate, the Maine Red Claws. In 32 D-League games, Jackson averaged 14.8 points, 6.0 assists, 5.1 rebounds, and 1.3 steals. In his NBA debut, Jackson had 8 points, 3 rebounds, and 2 assists in 11 minutes of play vs. Denver on Nov. 6, 2016. He averaged 9.3 points, 4.0 assists, 2.8 rebounds, and 2.00 steals while shooting 46.4% from the floor and 50.0% from 3-point range for Boston in the MGM Resorts NBA Summer League 2017." />
<meta name="twitter:title" content="Rockets Sign Demetrius Jackson to Two-Way Contract - Houston Forward Times" />
<meta name="twitter:image" content="http://forwardtimes.com/wp-content/uploads/2017/08/Rockets-Two-Way-Contract.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Feed" href="http://forwardtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Comments Feed" href="http://forwardtimes.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-55776444-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-55776444-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/forwardtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/css/settings.css?ver=4.6.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='style_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/prettyphoto.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/bootstrap.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/font-awesome.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='responsive_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/responsive.css?ver=4.8.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/forwardtimes.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.2'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/themes/medianews-theme/scripts/frontend/functions.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://forwardtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://forwardtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://forwardtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<meta name="generator" content="WooCommerce 3.1.2" />
<link rel='shortlink' href='http://forwardtimes.com/?p=16375' />
<link rel="alternate" type="application/json+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Frockets-sign-demetrius-jackson-two-way-contract%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Frockets-sign-demetrius-jackson-two-way-contract%2F&#038;format=xml" />
<div id="fb-root"></div><script>(function(d, s, id) {

	var js, fjs = d.getElementsByTagName(s)[0];

	if (d.getElementById(id)) return;

	js = d.createElement(s); js.id = id;

	js.src = '//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.3';

	fjs.parentNode.insertBefore(js, fjs);

	}(document, 'script', 'facebook-jssdk'));</script>		<script type="text/javascript">
			jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = 'aef5f63866';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"http://forwardtimes.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});
		</script>
		<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="fe6826430f3c55c1ea5ffe4e97aadc77910ae279d4bd39b95fb0d103f7927acc" async></script>	
			<style type="text/css">
			.pix-colr, .pix-colrhvr:hover,.breadcrumbs ul li.pix-active,#footer p a:hover,.is-countdown span:before,.latest-video .minus-column article:hover h2 a,
	/* New Clases Add*/.event-listing article:hover .text .pix-post-title a,.blog-medium-options li a,.is-countdown span,.pix-blog article:hover h2.pix-post-title a,
	.pix-blog article .post-options li a:hover,.tabs.horizontal .nav-tabs li.active a,.blog-home .tabs.horizontal .nav-tabs li:hover a { color:#00108e !important;
			}
			.pix-bgcolr,.pix-bgcolrhvr:hover,.cart-sec span,.navigation ul ul li:hover > a,.navigation ul > li.current-menu-item > a,
			.navigation ul ul li.current-menu-item > a,.cycle-pager-active,.widget .tagcloud a:hover,.flex-direction-nav li a:hover, .our-team-sec article:hover figure figcaption .pix-post-title a,.footer-widget .widget_newsletter .error,.news-section article:hover .text,.password_protected form input[type="submit"],.team-vertical article figcaption .caption h2,
	#respond form input[type="submit"],#wp-calendar caption,.gallery ul li figure figcaption a,.woocommerce-pagination ul li a:hover,.woocommerce-pagination ul li span,.woocommerce-tabs .tabs .active a, span.match-category.cat-neutral, .event.event-listing article:hover .text .btn,.widget_search form input[type="submit"], .woocommerce .button,.onsale,.gallery ul li:hover .text,.footer-icons .followus a:hover,
	/* New Clases Add*/.searchform button,.tabs.horizontal .nav-tabs li.active a,p.stars span a.active,.event.event-listing.event-listing-v2 .btn-viewall,.featured-title,.next-post-paginate a:hover,
	.pix-feature article .blog-bottom .btn,.pix-feature .featured,.blog-vertical .tab-content header.pix-heading-title h2,header #lang_sel a:hover, header #lang_sel ul ul a:hover,
	.post-tags a:hover,.pix-tittle,nav.navigation > ul > li:hover > a, nav.navigation > ul > li.current-menu-ancestor > a,.table tbody tr:hover,.widget_newsletter label .btn,.detail_figure .mejs-audio.mejs-container .mejs-controls,
	.detail_figure .mejs-audio.mejs-container,.latest-video .minus-column article:hover .uppercase,.flexslider ul li .caption h2,.pagination > ul > li > span.active,.pagination > ul > li > a.active, .pagination > ul > li > a:hover,.widget_nav_menu ul li a:hover, .widget_nav_menu ul li ul li a:hover, .widget_pages ul li a:hover,
	.widget_recent_entries ul li:hover, .widget_recent_comments ul li:hover, .widget_archive ul li:hover, .widget_links ul li:hover, .widget_meta ul li:hover, .widget_layered_nav ul li:hover, .widget_categories ul li:hover,
	h2 .bbp-forum-title,.widget .bbp-forum-title:hover, .widget .bbp-view-title:hover,#respond > h3:after{
				background-color:#00108e !important;
			}
			.pix-bdrcolr ,.tabs.horizontal .nav-tabs li.active,.address-info .text,.subtitle h1,.about-us article .text,blockquote,.blog-gallery .sliderpagination ul li.cycle-pager-active figure:before,
			.footer-icons .followus a:hover,.px-mega-menu > li > a:before,header.pix-heading-title h2:before,.blog-banner-carousel figure:before,.tabs.horizontal .nav-tabs li.active a {
				border-color:#00108e !important;
			}
			#banner .flexslider figcaption .pix-desc h3 span {
			   box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important; 
			}
			.our-team-sec article:hover figure figcaption .pix-post-title a{
				 box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important;   
			}
			.latest-video .minus-column article:hover figure{
				 box-shadow: 0 0 0 2px #00108e;
			}
			.footer-widget{
				background-color:#222222 !important;
			}
			header#header .top-head, .inner-sec{
				background-color:#0d549b !important;
			}
			nav.navigation > ul > li > a, li.sub-mega-menu .px-mega-menu ul li a, .sub-menu > li a, .px-mega-menu li a{
				color:#c6c6c6 !important;
			}
			heade #mainheader{
				background-color:#0d549b !important;
			}
			.sliderpagination ul li:before{
				border-color: transparent #00108e !important;
			}
			.footer-widget .widget_newsletter .error:before{
				border-top-color: #00108e !important;
			}
			body{
				 background:#1e73be url(); 			}
			
			</style>
				<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
			<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #0d549b; }
</style>
    
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-55776444-1', 'auto');
  ga('send', 'pageview');

</script>

</head>
	<body class="post-template-default single single-post postid-16375 single-format-standard custom-background" >
		<div id="wrappermain-pix" class="wrapper wrapper_boxed">
		<!-- Header Start -->
        <div class="mainheader">
            <!-- Top Strip Start -->
            
  
			
            <div class="top-strip">
                <!-- Top Nav Start -->
                <nav class="top-nav">
                    <ul id="top_menus"><li id="menu-item-7948" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/advertise/">ADVERTISE</a></li>
<li id="menu-item-8019" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/houston-forward-times/">ABOUT HFT</a></li>
<li id="menu-item-14098" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://forwardtimes.com/product-category/newspaper-subscription-options/">PURCHASE SUBSCRIPTION</a></li>
<li id="menu-item-8719" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://www.jlcsfoundation.org">JLCS FOUNDATION</a></li>
<li id="menu-item-8239" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/privacy-policy-terms-of-use/">PRIVACY &#038; TERMS</a></li>
<li id="menu-item-7944" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/contact-us/">CONTACT</a></li>
</ul>                </nav>
                <!-- Top Nav End -->
                     
                         <!-- Search Start -->
                         <div class="searchform">
                            		<form id="searchform" method="get" action="http://forwardtimes.com"  role="search">
			
			<input name="s" id="searchinput" value="Search for:" type="text" />
			<button> <i class="fa fa-search"></i></button>
		</form>
	                        </div>
                         <!-- Search End -->
                              </div>
            
                 
            <!-- Top Strip End -->
            <div class="container">
                <!-- Top Header Start -->
                <div class="top-head">
                    <div class="logo">
                        				<a href="http://forwardtimes.com">
                	<img src="http://forwardtimes.com/wp-content/uploads/2016/01/hftlogo.png"  style="width:px; height:px" 
                    alt="Houston Forward Times" />
                </a>
	 		                    </div>
                                             <div class="rightheader">
                            <div class="widget widget_text">
                                <div class="textwidget">
                                    <div class="ads-banner">
                                        <div class="top_banner">
                                        <div class="widget widget_text">			<div class="textwidget"><p><script src="//ap.lijit.com/www/delivery/fpi.js?z=490973&#038;width=728&#038;height=90"></script> </p>
</div>
		</div>                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                                    </div>
                <!-- Top Header End -->
                <div class="inner-sec pix-bdrcolr">
                    <nav class="navigation">
                    	<a class="cs-click-menu"><i class="fa fa-bars"></i></a>
                    	<ul id="menus"><li id="menu-item-7877" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-home"><a href="http://forwardtimes.com/">Home</a></li>
<li id="menu-item-7881" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/state-local/">State &#038; Local</a></li>
<li id="menu-item-7878" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/national-news/">National News</a></li>
<li id="menu-item-8240" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/business/">BUSINESS</a>
<ul class="sub-menu">
	<li id="menu-item-8667" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/careers/">CAREERS</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-12009" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li id="menu-item-12011" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/commentary/">Commentary</a></li>
	<li id="menu-item-12008" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/jboney-speaks/">JBoney Speaks</a></li>
	<li id="menu-item-12010" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/letters-to-the-editor/">Letters To The Editor</a></li>
	<li id="menu-item-7981" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/">Op-Ed</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-7879" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://forwardtimes.com/category/sports/">Sports</a></li>
<li id="menu-item-8043" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-7880" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-8714" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-8715" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/fashion/">Fashion</a></li>
	<li id="menu-item-8020" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/health-beauty/">Health &#038; Beauty</a></li>
	<li id="menu-item-8716" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/religious/">Religion</a></li>
	<li id="menu-item-8717" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/society/">Society</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-8718" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/classifieds/">Classifieds</a></li>
</ul>                    </nav>
                    <!-- Wp Sec Start -->
                     		<div class="wp-sec">
					 </div>
		                       <!-- Wp Sec End -->
                </div>
                		<!-- News Section Start -->
		<div class="news-section">
			<!-- Ticker Section -->
			<div class="ticker-sec">
					<div class="outer-newsticker">
    
                    <div class="announcement-ticker">
                <h2>Headlines</h2>                                <script>
                	jQuery(document).ready(function(){
                	    px_jsnewsticker('cls-news-ticker',50,80)
                	});
            	</script>
                <div class="ticker-wrapp">
                    <ul class="cls-news-ticker">
                                                <li>															
                              <a href="http://forwardtimes.com/don-sam-legendary-voice-houston-radio-celebrates-40-years/">Don Sam &#8211; The Legendary Voice of Houston Radio Celebrates 40 Years &nbsp; August 23, 2017</a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/texas-southern-new-home-texas-naacp-official-archives/">Texas Southern: New Home of the Texas NAACP Official Archives &nbsp; </a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/deshaun-watson-makes-houston-texans-home-debut-win-new-england-patriots/">Deshaun Watson Makes His Houston Texans’ Home Debut in Win against New England Patriots &nbsp; </a>
                          </li>
                                             </ul>
                </div>
                            </div>
                </div>
					 <!-- Follow Us Section -->
				<div class="followus">                    	<a title="" href="https://www.facebook.com/forwardtimesonline" data-original-title="Facebook" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-facebook-square icon"></i></a>
					                    	<a title="" href="https://twitter.com/forwardtimes" data-original-title="Twitter" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-twitter-square icon"></i></a>
					                    	<a title="" href="https://www.instagram.com/forwardtimes/" data-original-title="Instagram" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-instagram icon"></i></a>
					</div>			<!-- Follow Us Section -->
			</div>
		</div>
	    
                </div>
                <!-- News Section Start -->
            </div>
    <!-- Header Close -->
    <div class="clear"></div>
    <div id="main">
        <!-- Inner Main -->
        <div id="innermain">
                      <div class="container">
                <div class="row">

				<!--Left Sidebar Starts-->

<!--Left Sidebar End-->
<div class="col-md-12" >
  <div class="blog blog_detail">
    <article>
      <figure class="detail_figure"><img src="http://forwardtimes.com/wp-content/uploads/2017/08/Rockets-Two-Way-Contract.jpg" alt="" ></figure>      <div class="pix-content-wrap">
        <div class="detail_text rich_editor_text">
           		<ul class="post-options">
        	
        	                	<li><i class="fa fa-user"></i>Written by: <a href="">via Houston Rockets</a></li>
                                 <li>
                 	<i class="fa fa-clock-o"></i>                    <time datetime="2017-08-23">                    </time>
                </li>
				<li><span class="fa fa-folder-open"></span> <a href="http://forwardtimes.com/category/sports/" rel="tag">Sports</a></li>		</ul>
	          <div class="subtitle"><h1 class="pix-page-title px-single-page-title">Rockets Sign Demetrius Jackson  to Two-Way Contract</h1></div>                      	<div class="detail-blog-text">
            <p>Houston Rockets General Manager Daryl Morey announced that the team has signed free agent guard Demetrius Jackson to a two-way contract.</p>
<p>NBA rosters have expanded from 15 to 17 players with the additional spots available for players under two-way contracts. Teams may have up to two players under two-way contracts who will spend the bulk of the season in the NBA G League (formerly NBA Development League) and not more than 45 days with their NBA team. Only players with four or fewer years of NBA service are able to sign two-way contracts, which can be for either one or two seasons.</p>
<p>Jackson (6-1, 201) was the 45th overall pick by Boston in the 2016 NBA Draft following his junior season at Notre Dame. He appeared in five games for the Celtics last season, spending the majority of 2016-17 assigned to their D-League affiliate, the Maine Red Claws. In 32 D-League games, Jackson averaged 14.8 points, 6.0 assists, 5.1 rebounds, and 1.3 steals.</p>
<p>In his NBA debut, Jackson had 8 points, 3 rebounds, and 2 assists in 11 minutes of play vs. Denver on Nov. 6, 2016. He averaged 9.3 points, 4.0 assists, 2.8 rebounds, and 2.00 steals while shooting 46.4% from the floor and 50.0% from 3-point range for Boston in the MGM Resorts NBA Summer League 2017.</p>
            </div>
                    </div>
        <!-- Share Post -->
        <div class="share-post">
          