<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><![endif]-->
    <title>
	Houston Forward Times | 
    AFTER THE STORM: Now it’s Time to Plan and Pick up the Pieces - Houston Forward Times    </title>
    <meta charset="UTF-8" />
	<link rel="shortcut icon" href="http://forwardtimes.com/wp-content/uploads/2015/12/hftfavicon.ico" />
    <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0">
<!-- This site is optimized with the Yoast SEO plugin v5.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://forwardtimes.com/storm-now-time-plan-pick-pieces/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="AFTER THE STORM: Now it’s Time to Plan and Pick up the Pieces - Houston Forward Times" />
<meta property="og:description" content="ABOVE: Deric Muhammad and Pastor E.A. Deckard hand out supplies This past week, the Greater Houston area experienced the worst natural disaster in recent memory, as the unprecedented flood waters produced from Hurricane Harvey ravished the area. Nearly 50&#8243; of rain, or roughly a year’s worth of rain, fell upon the Greater Houston area in 7 days, and according to the National Weather Service, Hurricane Harvey broke the record for total rainfall from a tropical system in the 48 contiguous U.S. states. It was a monster storm, with catastrophic results. The storm has since gone up north, but the remnants of the devastation left in the wake of the flooding from Hurricane Harvey still remain. The flood waters from Hurricane Harvey were non-discriminatory and impacted nearly everyone – regardless of their racial demographic, socio-economic status or geographic area. While the flooding did not discriminate, as it relates to who was impacted by the storm, there are still a tremendous number of disparities that exist amongst those who are poor and less fortunate. Some people have been left with absolutely nothing, and are scrambling to figure out how to pick up the pieces – many of those individuals are African American. Countless individuals have stepped up to the plate, catapulting themselves into the unlikely roles of heroes and (s)heroes in their respective communities &#8211; risking their lives, giving of their time and sacrificing their personal resources to help family members, friends, neighbors and even strangers escape the torrential flood waters, find safety and shelter, and attemptread more" />
<meta property="og:url" content="http://forwardtimes.com/storm-now-time-plan-pick-pieces/" />
<meta property="og:site_name" content="Houston Forward Times" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2017-09-06T14:58:58-05:00" />
<meta property="article:modified_time" content="2017-09-06T15:06:42-05:00" />
<meta property="og:updated_time" content="2017-09-06T15:06:42-05:00" />
<meta property="og:image" content="http://forwardtimes.com/wp-content/uploads/2017/09/harvey-deckard.jpg" />
<meta property="og:image:width" content="738" />
<meta property="og:image:height" content="461" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="ABOVE: Deric Muhammad and Pastor E.A. Deckard hand out supplies This past week, the Greater Houston area experienced the worst natural disaster in recent memory, as the unprecedented flood waters produced from Hurricane Harvey ravished the area. Nearly 50&#8243; of rain, or roughly a year’s worth of rain, fell upon the Greater Houston area in 7 days, and according to the National Weather Service, Hurricane Harvey broke the record for total rainfall from a tropical system in the 48 contiguous U.S. states. It was a monster storm, with catastrophic results. The storm has since gone up north, but the remnants of the devastation left in the wake of the flooding from Hurricane Harvey still remain. The flood waters from Hurricane Harvey were non-discriminatory and impacted nearly everyone – regardless of their racial demographic, socio-economic status or geographic area. While the flooding did not discriminate, as it relates to who was impacted by the storm, there are still a tremendous number of disparities that exist amongst those who are poor and less fortunate. Some people have been left with absolutely nothing, and are scrambling to figure out how to pick up the pieces – many of those individuals are African American. Countless individuals have stepped up to the plate, catapulting themselves into the unlikely roles of heroes and (s)heroes in their respective communities &#8211; risking their lives, giving of their time and sacrificing their personal resources to help family members, friends, neighbors and even strangers escape the torrential flood waters, find safety and shelter, and attemptread more" />
<meta name="twitter:title" content="AFTER THE STORM: Now it’s Time to Plan and Pick up the Pieces - Houston Forward Times" />
<meta name="twitter:image" content="http://forwardtimes.com/wp-content/uploads/2017/09/harvey-deckard.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/forwardtimes.com\/","name":"Houston Forward Times","alternateName":"The Houston Forward Times","potentialAction":{"@type":"SearchAction","target":"http:\/\/forwardtimes.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/forwardtimes.com\/storm-now-time-plan-pick-pieces\/","sameAs":[],"@id":"#organization","name":"Forward Times Publishing Company","logo":"http:\/\/forwardtimes.com\/wp-content\/uploads\/2015\/12\/ft250x100.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Feed" href="http://forwardtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Houston Forward Times &raquo; Comments Feed" href="http://forwardtimes.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-55776444-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-55776444-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/forwardtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/css/settings.css?ver=4.6.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='style_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/prettyphoto.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/bootstrap.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/font-awesome.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://forwardtimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='responsive_css-css'  href='http://forwardtimes.com/wp-content/themes/medianews-theme/css/responsive.css?ver=4.8.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/forwardtimes.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.2'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://forwardtimes.com/wp-content/themes/medianews-theme/scripts/frontend/functions.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://forwardtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://forwardtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://forwardtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='http://forwardtimes.com/?p=16519' />
<link rel="alternate" type="application/json+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Fstorm-now-time-plan-pick-pieces%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://forwardtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fforwardtimes.com%2Fstorm-now-time-plan-pick-pieces%2F&#038;format=xml" />
<div id="fb-root"></div><script>(function(d, s, id) {

	var js, fjs = d.getElementsByTagName(s)[0];

	if (d.getElementById(id)) return;

	js = d.createElement(s); js.id = id;

	js.src = '//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.3';

	fjs.parentNode.insertBefore(js, fjs);

	}(document, 'script', 'facebook-jssdk'));</script>		<script type="text/javascript">
			jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = '5d34f044de';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"http://forwardtimes.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});
		</script>
		<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="fe6826430f3c55c1ea5ffe4e97aadc77910ae279d4bd39b95fb0d103f7927acc" async></script>	
			<style type="text/css">
			.pix-colr, .pix-colrhvr:hover,.breadcrumbs ul li.pix-active,#footer p a:hover,.is-countdown span:before,.latest-video .minus-column article:hover h2 a,
	/* New Clases Add*/.event-listing article:hover .text .pix-post-title a,.blog-medium-options li a,.is-countdown span,.pix-blog article:hover h2.pix-post-title a,
	.pix-blog article .post-options li a:hover,.tabs.horizontal .nav-tabs li.active a,.blog-home .tabs.horizontal .nav-tabs li:hover a { color:#00108e !important;
			}
			.pix-bgcolr,.pix-bgcolrhvr:hover,.cart-sec span,.navigation ul ul li:hover > a,.navigation ul > li.current-menu-item > a,
			.navigation ul ul li.current-menu-item > a,.cycle-pager-active,.widget .tagcloud a:hover,.flex-direction-nav li a:hover, .our-team-sec article:hover figure figcaption .pix-post-title a,.footer-widget .widget_newsletter .error,.news-section article:hover .text,.password_protected form input[type="submit"],.team-vertical article figcaption .caption h2,
	#respond form input[type="submit"],#wp-calendar caption,.gallery ul li figure figcaption a,.woocommerce-pagination ul li a:hover,.woocommerce-pagination ul li span,.woocommerce-tabs .tabs .active a, span.match-category.cat-neutral, .event.event-listing article:hover .text .btn,.widget_search form input[type="submit"], .woocommerce .button,.onsale,.gallery ul li:hover .text,.footer-icons .followus a:hover,
	/* New Clases Add*/.searchform button,.tabs.horizontal .nav-tabs li.active a,p.stars span a.active,.event.event-listing.event-listing-v2 .btn-viewall,.featured-title,.next-post-paginate a:hover,
	.pix-feature article .blog-bottom .btn,.pix-feature .featured,.blog-vertical .tab-content header.pix-heading-title h2,header #lang_sel a:hover, header #lang_sel ul ul a:hover,
	.post-tags a:hover,.pix-tittle,nav.navigation > ul > li:hover > a, nav.navigation > ul > li.current-menu-ancestor > a,.table tbody tr:hover,.widget_newsletter label .btn,.detail_figure .mejs-audio.mejs-container .mejs-controls,
	.detail_figure .mejs-audio.mejs-container,.latest-video .minus-column article:hover .uppercase,.flexslider ul li .caption h2,.pagination > ul > li > span.active,.pagination > ul > li > a.active, .pagination > ul > li > a:hover,.widget_nav_menu ul li a:hover, .widget_nav_menu ul li ul li a:hover, .widget_pages ul li a:hover,
	.widget_recent_entries ul li:hover, .widget_recent_comments ul li:hover, .widget_archive ul li:hover, .widget_links ul li:hover, .widget_meta ul li:hover, .widget_layered_nav ul li:hover, .widget_categories ul li:hover,
	h2 .bbp-forum-title,.widget .bbp-forum-title:hover, .widget .bbp-view-title:hover,#respond > h3:after{
				background-color:#00108e !important;
			}
			.pix-bdrcolr ,.tabs.horizontal .nav-tabs li.active,.address-info .text,.subtitle h1,.about-us article .text,blockquote,.blog-gallery .sliderpagination ul li.cycle-pager-active figure:before,
			.footer-icons .followus a:hover,.px-mega-menu > li > a:before,header.pix-heading-title h2:before,.blog-banner-carousel figure:before,.tabs.horizontal .nav-tabs li.active a {
				border-color:#00108e !important;
			}
			#banner .flexslider figcaption .pix-desc h3 span {
			   box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important; 
			}
			.our-team-sec article:hover figure figcaption .pix-post-title a{
				 box-shadow: -10px  0 0 #00108e,10px  0 0 #00108e !important;   
			}
			.latest-video .minus-column article:hover figure{
				 box-shadow: 0 0 0 2px #00108e;
			}
			.footer-widget{
				background-color:#222222 !important;
			}
			header#header .top-head, .inner-sec{
				background-color:#0d549b !important;
			}
			nav.navigation > ul > li > a, li.sub-mega-menu .px-mega-menu ul li a, .sub-menu > li a, .px-mega-menu li a{
				color:#c6c6c6 !important;
			}
			heade #mainheader{
				background-color:#0d549b !important;
			}
			.sliderpagination ul li:before{
				border-color: transparent #00108e !important;
			}
			.footer-widget .widget_newsletter .error:before{
				border-top-color: #00108e !important;
			}
			body{
				 background:#1e73be url(); 			}
			
			</style>
					<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #0d549b; }
</style>
    
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-55776444-1', 'auto');
  ga('send', 'pageview');

</script>

</head>
	<body class="post-template-default single single-post postid-16519 single-format-standard custom-background" >
		<div id="wrappermain-pix" class="wrapper wrapper_boxed">
		<!-- Header Start -->
        <div class="mainheader">
            <!-- Top Strip Start -->
            
  
			
            <div class="top-strip">
                <!-- Top Nav Start -->
                <nav class="top-nav">
                    <ul id="top_menus"><li id="menu-item-7948" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/advertise/">ADVERTISE</a></li>
<li id="menu-item-8019" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/houston-forward-times/">ABOUT HFT</a></li>
<li id="menu-item-14098" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://forwardtimes.com/product-category/newspaper-subscription-options/">PURCHASE SUBSCRIPTION</a></li>
<li id="menu-item-8719" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="http://www.jlcsfoundation.org">JLCS FOUNDATION</a></li>
<li id="menu-item-8239" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/privacy-policy-terms-of-use/">PRIVACY &#038; TERMS</a></li>
<li id="menu-item-7944" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://forwardtimes.com/contact-us/">CONTACT</a></li>
</ul>                </nav>
                <!-- Top Nav End -->
                     
                         <!-- Search Start -->
                         <div class="searchform">
                            		<form id="searchform" method="get" action="http://forwardtimes.com"  role="search">
			
			<input name="s" id="searchinput" value="Search for:" type="text" />
			<button> <i class="fa fa-search"></i></button>
		</form>
	                        </div>
                         <!-- Search End -->
                              </div>
            
                 
            <!-- Top Strip End -->
            <div class="container">
                <!-- Top Header Start -->
                <div class="top-head">
                    <div class="logo">
                        				<a href="http://forwardtimes.com">
                	<img src="http://forwardtimes.com/wp-content/uploads/2016/01/hftlogo.png"  style="width:px; height:px" 
                    alt="Houston Forward Times" />
                </a>
	 		                    </div>
                                             <div class="rightheader">
                            <div class="widget widget_text">
                                <div class="textwidget">
                                    <div class="ads-banner">
                                        <div class="top_banner">
                                        <div class="widget widget_text">			<div class="textwidget"><p><div class="ads-banner"><div class="top_banner"><a href="http://www.hccs.edu/go" target="_blank"><img src="http://forwardtimes.com/wp-content/uploads/2017/08/HCC_Fall2017_825x125.jpg" alt="HCC Fall 2017 banner"></a></div></div></p>
</div>
		</div>                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                                    </div>
                <!-- Top Header End -->
                <div class="inner-sec pix-bdrcolr">
                    <nav class="navigation">
                    	<a class="cs-click-menu"><i class="fa fa-bars"></i></a>
                    	<ul id="menus"><li id="menu-item-7877" class="menu-item  menu-item-type-post_type  menu-item-object-page  menu-item-home"><a href="http://forwardtimes.com/">Home</a></li>
<li id="menu-item-7881" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://forwardtimes.com/category/state-local/">State &#038; Local</a></li>
<li id="menu-item-7878" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/national-news/">National News</a></li>
<li id="menu-item-8240" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/business/">BUSINESS</a>
<ul class="sub-menu">
	<li id="menu-item-8667" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/careers/">CAREERS</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-12009" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li id="menu-item-12011" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/commentary/">Commentary</a></li>
	<li id="menu-item-12008" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/jboney-speaks/">JBoney Speaks</a></li>
	<li id="menu-item-12010" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/letters-to-the-editor/">Letters To The Editor</a></li>
	<li id="menu-item-7981" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/editorial/op-ed/">Op-Ed</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-7879" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/sports/">Sports</a></li>
<li id="menu-item-8043" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-7880" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://forwardtimes.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-8714" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-8715" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/fashion/">Fashion</a></li>
	<li id="menu-item-8020" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/health-beauty/">Health &#038; Beauty</a></li>
	<li id="menu-item-8716" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/religious/">Religion</a></li>
	<li id="menu-item-8717" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/lifestyle/society/">Society</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-8718" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://forwardtimes.com/category/classifieds/">Classifieds</a></li>
</ul>                    </nav>
                    <!-- Wp Sec Start -->
                     		<div class="wp-sec">
					 </div>
		                       <!-- Wp Sec End -->
                </div>
                		<!-- News Section Start -->
		<div class="news-section">
			<!-- Ticker Section -->
			<div class="ticker-sec">
					<div class="outer-newsticker">
    
                    <div class="announcement-ticker">
                <h2>Headlines</h2>                                <script>
                	jQuery(document).ready(function(){
                	    px_jsnewsticker('cls-news-ticker',50,80)
                	});
            	</script>
                <div class="ticker-wrapp">
                    <ul class="cls-news-ticker">
                                                <li>															
                              <a href="http://forwardtimes.com/ram-bush-texas-black-expo-emmy-award-winning-producer-rushion-mcdonald-join-forces-financially-help-small-businesses-affected-hurricane-harvey/">Texas Black Expo and Emmy® Award-Winning Producer Rushion McDonald Join Forces to Help Small Businesses Affected by Hurricane Harvey &nbsp; September 6, 2017</a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/storm-now-time-plan-pick-pieces/">AFTER THE STORM: Now it’s Time to Plan and Pick up the Pieces &nbsp; </a>
                          </li>
                                                   <li>															
                              <a href="http://forwardtimes.com/thousands-ministers-march-justice-peace-political-laryngitis/">Thousands of Ministers March for Justice and Peace, Against ‘Political Laryngitis’ and to hold the Trump White House accountable. &nbsp; </a>
                          </li>
                                             </ul>
                </div>
                            </div>
                </div>
					 <!-- Follow Us Section -->
				<div class="followus">                    	<a title="" href="https://www.facebook.com/forwardtimesonline" data-original-title="Facebook" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-facebook-square icon"></i></a>
					                    	<a title="" href="https://twitter.com/forwardtimes" data-original-title="Twitter" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-twitter-square icon"></i></a>
					                    	<a title="" href="https://www.instagram.com/forwardtimes/" data-original-title="Instagram" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-instagram icon"></i></a>
					</div>			<!-- Follow Us Section -->
			</div>
		</div>
	    
                </div>
                <!-- News Section Start -->
            </div>
    <!-- Header Close -->
    <div class="clear"></div>
    <div id="main">
        <!-- Inner Main -->
        <div id="innermain">
                      <div class="container">
                <div class="row">

				<!--Left Sidebar Starts-->

<!--Left Sidebar End-->
<div class="col-md-9" >
  <div class="blog blog_detail">
    <article>
      <figure class="detail_figure"><img src="http://forwardtimes.com/wp-content/uploads/2017/09/harvey-deckard.jpg" alt="" ></figure>      <div class="pix-content-wrap">
        <div class="detail_text rich_editor_text">
           		<ul class="post-options">
        	
        	                	<li><i class="fa fa-user"></i>Written by: <a href="http://forwardtimes.com/author/jlb/">Jeffrey L. Boney</a></li>
                                 <li>
                 	<i class="fa fa-clock-o"></i>                    <time datetime="2017-09-06">                    </time>
                </li>
				<li><span class="fa fa-folder-open"></span> <a href="http://forwardtimes.com/category/featured/" rel="tag">Featured</a>, <a href="http://forwardtimes.com/category/state-local/" rel="tag">State &amp; Local</a></li>		</ul>
	          <div class="subtitle"><h1 class="pix-page-title px-single-page-title">AFTER THE STORM: Now it’s Time to Plan and Pick up the Pieces</h1></div>                      	<div class="detail-blog-text">
            <p dir="LTR" align="JUSTIFY"><em><strong>ABOVE: Deric Muhammad and Pastor E.A. Deckard hand out supplies</strong></em></p>
<p dir="LTR" align="JUSTIFY">This past week, the Greater Houston area experienced the worst natural disaster in recent memory, as the unprecedented flood waters produced from Hurricane Harvey ravished the area.</p>
<p dir="LTR" align="JUSTIFY">Nearly 50&#8243; of rain, or roughly a year’s worth of rain, fell upon the Greater Houston area in 7 days, and according to the National Weather Service, Hurricane Harvey broke the record for total rainfall from a tropical system in the 48 contiguous U.S. states. It was a monster storm, with catastrophic results.</p>
<p dir="LTR" align="JUSTIFY">The storm has since gone up north, but the remnants of the devastation left in the wake of the flooding from Hurricane Harvey still remain.</p>
<p dir="LTR" align="JUSTIFY">The flood waters from Hurricane Harvey were non-discriminatory and impacted nearly everyone – regardless of their racial demographic, socio-economic status or geographic area.</p>
<p dir="LTR" align="JUSTIFY">While the flooding did not discriminate, as it relates to who was impacted by the storm, there are still a tremendous number of disparities that exist amongst those who are poor and less fortunate. Some people have been left with absolutely nothing, and are scrambling to figure out how to pick up the pieces – many of those individuals are African American.</p>
<p dir="LTR" align="JUSTIFY">Countless individuals have stepped up to the plate, catapulting themselves into the unlikely roles of heroes and (s)heroes in their respective communities &#8211; risking their lives, giving of their time and sacrificing their personal resources to help family members, friends, neighbors and even strangers escape the torrential flood waters, find safety and shelter, and attempt to deal with the recovery phase of their lives after the storm.</p>
<p>This recovery effort has not been about one or two individuals doing all the work, or about who the big I’s and the little U’s are. This recovery effort has seen, however, many of the usual suspects rise to the occasion, once again, to deal with a crisis that many have faced since this catastrophic event took place.</p>
<p dir="LTR" align="JUSTIFY">Many individuals recall last year’s storm, often referred to as the &#8220;Tax Day Flood,&#8221; because April 15 fell on a weekend and got pushed to April 18 as result.</p>
<p dir="LTR" align="JUSTIFY">On April 17, the storm dropped nearly 17 inches of rain across the Greater Houston area, and continued through to April18. Because of the heavy flooding, a total of 8 people died, all in their cars, and 700+ homes and apartments flooded.</p>
<p dir="LTR" align="JUSTIFY">One of the areas heavily impacted during the &#8220;Tax Day Flood&#8221; last year was the Greenspoint area, located near 45 North Freeway and Beltway 8, where people found themselves without rescue boats and without a means to escape the flood waters without assistance.</p>
<p dir="LTR" align="JUSTIFY">During that time, people like community activist Deric Muhammad and Pastor E.A. Deckard, immediately sprang into action, doing the best they could to rescue individuals and provide the immediate needs of the people. Many other unsung heroes and (s)heroes joined forces with Muhammad and Deckard during the &#8220;Tax Day Flood&#8221; to help make a difference.</p>
<p dir="LTR" align="JUSTIFY">Now, fast forward to the recent flooding caused by Hurricane Harvey, and Muhammad and Deckard are at it again, helping provide the immediate needs of the people by setting up donation drop-off and pick-up spots all across the Greater Houston area, in order to get resources directly into the hands of the people who need them. This time, however, the devastation is wider, and the needs are much greater.</p>
<p dir="LTR" align="JUSTIFY">There is no way anyone could have been able to fully predict the type of devastation and catastrophic results of Hurricane Harvey, or the level of calamity that any natural disaster will cause; but the one thing individuals in the Greater Houston area can proactively do is organize and be better prepared to deal with a natural disaster or crisis whenever it arises – especially in a place like the Greater Houston area which is historically known for its propensity to flooding.</p>
<p dir="LTR" align="JUSTIFY">Granted, there must be something done about the aging infrastructure in Houston, but until that is properly dealt with and resolved, individuals have to do everything in their power to protect themselves.</p>
<p dir="LTR" align="JUSTIFY">For many African Americans in the Greater Houston area, they find it difficult not to be concerned about the level of attention they may or may not receive in their respective neighborhoods during any type of crisis or disaster – natural or man-made -particularly as it relates to emergency rescue response times or resources dispersed to their communities.</p>
<p dir="LTR" align="JUSTIFY">Complaints about a lack of response from FEMA, state agencies, disaster recovery organizations and local elected officials, are customary during times like these, and in many cases justifiable.</p>
<p dir="LTR" align="JUSTIFY">It is time that local communities become more engaged, and begin to take ownership of what happens in their communities, particularly as it relates to dealing with the aftermath of a future natural disaster &#8211; which could very well be right around the corner.</p>
<p dir="LTR" align="JUSTIFY">As a result of Hurricane Harvey, several local community organizations, entities and institutions have begun meeting and discussing ways in which they can work together in proactive unity in order to strategize, organize, prepare and be ready to mobilize whenever a future crisis or disaster strikes.</p>
<p dir="LTR" align="JUSTIFY">Imagine if these types of progressive meetings were taking place all across the Greater Houston area.</p>
<p dir="LTR" align="JUSTIFY">If African Americans were to take a look at nearly every major aspect of their lives, it is clear the African American community does not have collective control over the things that impact their daily lives, especially when it comes to dealing with a crisis or a natural disaster.</p>
<p dir="LTR" align="JUSTIFY">Now is the time to move away from being collectively reliant and solely dependent on other people, other organizations and heavily dependent on local, county, state and federal governments to take care of the needs of the African American community whenever circumstances become dire and in times where the community is in its weakest and most vulnerable position.</p>
<p dir="LTR" align="JUSTIFY">For those who were blessed enough to not receive any damage from Hurricane Harvey, now is not the time to sit on the sidelines and just watch. Please find a way to help those who are still dealing with the devastation and recovery aspect of the storm.</p>
<p dir="LTR" align="JUSTIFY">Your time, talent and treasure are needed – now more than ever.</p>
<p dir="LTR" align="JUSTIFY">The Forward Times is currently working with a remnant of committed local community groups, organizations and individuals, who are focused on standing together and moving forward, by developing a solid community engagement plan, while also helping to rebuild better communities for current and future generations of Greater Houston area residents.</p>
<p dir="LTR" align="JUSTIFY">They must feel safe and excited about their future. Now is the time!!!</p>
<p dir="LTR" align="JUSTIFY">Next week, the Forward Times will provide our readers with a Hurricane Harvey Recovery Roadmap Special Edition with critical information for our readers to have access to as we deal with the aftermath of this catastrophic and life-altering storm.</p>
<p>Stay tuned and we are here to help if you need us!</p>
            </div>
                    </div>
        <!-- Share Post -->
        <div class="share-post">
          